42985 usb bridge cable driver for windows 7 ultimate 64bit

USB 2.0 - USB 3.0 - FireWire - Hubs - Cables - Adapters
9 posts Page 1 of 1
mihaly.reg
New member
Posts: 5
Joined: Sun Feb 23, 2014 8:00 am
by mihaly.reg » Sun Feb 23, 2014 8:07 am
USB 2.0 Docking Station Pro 42985. In Windows 7 Ultimate 64bit it is not detected as USB Bridge Cable.
Tried on 2 different hardware.
On Windows XP it works fire, the hardware is detected as VID_067B&PID_0000
On both windows 7 it is detected as unknown device with VID_0000&PID_0000

What is the problem? I'm missing something here? I have searched lindy.co.uk for win7 driver but not found any.

 

LINDY Shippers
LINDY Staff
Posts: 655
Joined: Wed Mar 17, 2010 1:32 pm
 
by LINDY Shippers » Mon Feb 24, 2014 9:10 am
I'm afraid support ended at vista. Have you tried the vista driver?

http://www.lindy.co.uk/drivers_and_manuals/search/42985

Chris

 

mihaly.reg
New member
Posts: 5
Joined: Sun Feb 23, 2014 8:00 am
by mihaly.reg » Wed Feb 26, 2014 10:53 pm
Got the vista driver you linked and unpacked it but it seems that it's ethernet and serial port only. I don't see any folder of file for USB Bridge Cable ! Maybe it didn't worked in vista either??
Actually the AX8xxx ethernet and the serial port is already working for me in Windows 7 by default, I think Microsoft have the drivers for it.
Anyway, I have installed this driver you linked ... and of course nothing changed.
USB Bridge is still "Unknown" in my device manager.
Is there any way to convert the XP driver to Windows 7 ?
Thanks man !

 

LINDY Shippers
LINDY Staff
Posts: 655
Joined: Wed Mar 17, 2010 1:32 pm
 
by LINDY Shippers » Thu Feb 27, 2014 9:00 am
I'm afraid you cannot port a driver from XP to Windows 7.

Which part of the product isn't working due to the USB bridge driver not installing?

Chris

 

mihaly.reg
New member
Posts: 5
Joined: Sun Feb 23, 2014 8:00 am
by mihaly.reg » Thu Feb 27, 2014 12:29 pm
The USB bridge part is the only one not working. Fortunatelly for all the rest (eth, serial, parallel) Microsoft had the default drivers and come up when I plugged in.
For the USB Brigde I tried to lookup on internet for the generic driver of the chip but have no luck :-(

Late edit: I see in first post I stated that "On both windows 7 it is detected as unknown device with VID_0000&PID_0000" , but yesterday was playing around in device manager and I saw "VID_067B&PID_0000". Really not sure what's happening. I'm pretty sure first time was null, now it;s 067b, but don't know why.
Well, anyway the device is not working either with 067b.... just told you what happened to avoid confusions.
Thanks !
Attachments
2014-02-27_224344.jpg
2014-02-27_224344.jpg (96.93 KiB) Viewed 1387 times
Last edited by mihaly.reg on Thu Feb 27, 2014 9:45 pm, edited 1 time in total.

 

mihaly.reg
New member
Posts: 5
Joined: Sun Feb 23, 2014 8:00 am
by mihaly.reg » Thu Feb 27, 2014 9:46 pm
device manager hw id

edit: this forum does not upload the second picture. it starts asking me questions like planet eart, say hello or other stuff but does not upload the second picture. the content what I wanted to upload is this: Other devices > Unknown Device > Properties > Details Hardware IDs > USB\VID_067B&PID_0000&REV_0000
Last edited by mihaly.reg on Thu Feb 27, 2014 9:52 pm, edited 1 time in total.

 

LINDY Shippers
LINDY Staff
Posts: 655
Joined: Wed Mar 17, 2010 1:32 pm
 
by LINDY Shippers » Fri Feb 28, 2014 8:59 am
It is not supported on Windows 7/8 and it never will be.

As a last ditch effort, could you try the attached software?
Attachments
PCLinq3_Generic_3103.zip
(2.25 MiB) Downloaded 61 times

 

mihaly.reg
New member
Posts: 5
Joined: Sun Feb 23, 2014 8:00 am
by mihaly.reg » Fri Feb 28, 2014 6:17 pm
Thanks but the zip is invalid. Please upload again.

Edit: sorry my fault, 7-zip does not open it but with windows zip it is ok.
I will install now and test.

Edit2: unfortunately it does not work. And it's worst then the original windows driver, now the serial port is also with yellow mark. I will uninstall this.

There is a chance to get a driver from Prolific ? This is the manufacturer of the USB Bridge chipset, right ? Maybe their chip was embedded in other devices and that device manufacturers released Win7 drivers ?
I could not found anything useful on the internet, but maybe you have direct contact with Prolific and can talk to them about similar devices drivers ? It would be nice to post here also the chip model number, do you know it ? I don't know, I guess I should disassemble the device to find out.

Thanks, I really appreciate your support!
Last edited by mihaly.reg on Fri Feb 28, 2014 6:57 pm, edited 1 time in total.

 

LINDY Shippers
LINDY Staff
Posts: 655
Joined: Wed Mar 17, 2010 1:32 pm
 
by LINDY Shippers » Mon Mar 03, 2014 9:09 am
The chip was discontinued by prolific a long time ago and to be honest I doubt they talk to end users.

That software was from a newer package that should of been compatible with the chip / windows 7, however it isn't working.

There is nothing else I can do, sorry.

Chris
9 posts Page 1 of 1