Page 1 of 1

BNX60 not charging

Posted: Sun Nov 12, 2017 1:04 pm
by koincidencia
I bought my BNX60 headphones about a month ago, now it does not want to charge. Unfortunately, I can't remember if the battery was empty yesterday when I put it away. I measure 0.6mA current through the USB cable when I plug it in into the headphone. It does nothing if I press (for a couple of seconds) the play/multifunction button, but the ANC LED is lit blue if I turn on the ANC functionality with the switch. What could be wrong with my headphone?

Re: BNX60 not charging

Posted: Sun Nov 12, 2017 2:31 pm
by koincidencia
I've found the solution. I've disassembled the left cover and desoldered the battery positive wire from the PCB. After a few seconds resoldered it, and now it works perfectly. So cutting the power from the board ("hard reset") solved the problem. I think maybe the software in the microcontroller got frozen and needed a reset. It would be nice if the user could do this kind of reset without the need of soldering (for example a small normally closed tactile switch could do that). On the other hand, I really like the design of the headphone from a technical viewpoint, it was easy to repair.

Re: BNX60 not charging

Posted: Thu Oct 11, 2018 10:18 am
by iosman
BNX60 not charging- I was looking for this post so long but didn’t find this solution, now I have finally found this solution, thanks for this awesome post.